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IMPORTANT! Safety Information 

Safety Classifications 

Note: 
Provides special information for installing, configuring, and operating the 
equipment. 

 IMPORTANT! 
Provides special information that is critical to installing, configuring, and 
operating the equipment. 

 CAUTION! 
Provides special information on avoiding situations that may cause damage 
to equipment. 

 WARNING! 
Provides special information on avoiding situations that may cause physical 
danger to the installer, end user, etc. 

 ELECTRIC SHOCK! 
The source power poses an electric shock hazard that has the potential to 
cause serious injury to installers and end users. 

 ELECTRICAL DISCONNECT: 

The source power outlet and power supply input power sockets should be 
easily accessible to disconnect power in the event of an electrical hazard or 
malfunction. 

 WEIGHT INJURY!  
Installing some of the equipment requires two installers to ensure safe 
handling during installation. Failure to use two installers may result in injury. 

Safety Statements 
1. Read these instructions in their entirety and retain a copy for later reference. 

2. Follow all instructions and heed all warnings. 

3. Do not expose this apparatus to rain, moisture, sprays, drips or splashes and ensure that no objects containing liquids are 
placed on the apparatus, including cups, glasses and vases.  

4. Do not place this unit in a confined space such as enclosed shelving, cabinets or bookshelves. Ensure the unit is 
adequately ventilated.  

5. To prevent the risk of electric shock or fire hazard due to overheating, do not cover the unit or obstruct ventilation 
openings with material, newspaper, cardboard or anything that may restrict airflow into the unit.  

6. Do not install near external heat sources such as radiators, heat registers, boilers or any device that produces heat such 
as amplifiers or computers and do not place near sources of naked flame.  

7. Unplug apparatus from power supply during lightning storms or when unused for long periods of time.  

8. Protect the power cable from being walked on, pinched or restricted in any way, especially at plug connections.  

9. Only use attachments/accessories specified by the manufacturer.  

10. Units contain non-serviceable parts - Refer all servicing to qualified service personnel.  

 IMPORTANT! 
Do Not Hot swap connections - Please insert and extract cables carefully with the power SWITCHED OFF. 
Power is passed along transmissions so connecting and disconnecting cables while powered can result in 
damage to circuitry or possible injury. 

  

http://www.wyrestorm.com/
mailto:support@WyreStorm.com


© Copyright 2018 WyreStorm Technologies | wyrestorm.com 
Enado Installation Manual | 180808 

3 of 38 
UK: +44 (0) 1793 230 343 | ROW: 844.280.WYRE (9973)   

Email: support@wyrestorm.com 
 

Contents 

IMPORTANT! Safety Information ..................................................................................................................... 2 

Contents ........................................................................................................................................................ 3 

1 Introduction ................................................................................................................................................ 4 
Before Beginning ............................................................................................................................................................................................. 4 

2 Product Overview ........................................................................................................................................ 5 
In the Box .......................................................................................................................................................................................................... 5 
ENA-001-010 Front and Rear Panel ............................................................................................................................................................ 6 
ENA-MINI-010 Front and Rear Panel........................................................................................................................................................... 7 
Typical Application .......................................................................................................................................................................................... 7 

3 Installation ............................................................................................................................................... 10 
Shelf Placement ............................................................................................................................................................................................ 10 
Rack Placement............................................................................................................................................................................................. 10 
Wiring and Connections ............................................................................................................................................................................... 10 

4 Configuration ............................................................................................................................................ 11 
Connection Steps .......................................................................................................................................................................................... 11 
Locating Enado on the Network ................................................................................................................................................................. 11 

5 Product Operation ..................................................................................................................................... 12 
Accessing the User Interface ...................................................................................................................................................................... 12 
Updating Firmware ....................................................................................................................................................................................... 12 
Setting a Static IP .......................................................................................................................................................................................... 12 
Creating Your First Project .......................................................................................................................................................................... 12 
Configuring Control (IR, IP, RS232) ............................................................................................................................................................ 14 
Downloading Device Commands ............................................................................................................................................................... 17 
Viewing and Testing Commands ............................................................................................................................................................... 19 
Adding Control Buttons ................................................................................................................................................................................ 20 
Source Control (Activity Layouts) ............................................................................................................................................................... 23 
Wizards ........................................................................................................................................................................................................... 24 
Uploading Custom Icons ............................................................................................................................................................................. 25 
Visual Theme ................................................................................................................................................................................................. 25 
QR Codes ........................................................................................................................................................................................................ 26 
Remote Access .............................................................................................................................................................................................. 27 
Timed Commands ........................................................................................................................................................................................ 28 
Triggered Commands................................................................................................................................................................................... 28 
Adding a Video Preview ................................................................................................................................................................................ 29 
Integrating Amazon Echo (Alexa) ............................................................................................................................................................... 30 
Publishing a Project ...................................................................................................................................................................................... 33 
Preferences Menu ......................................................................................................................................................................................... 34 
Project & Controller Backup ......................................................................................................................................................................... 35 
GPIO (Relays & Sensors) .............................................................................................................................................................................. 35 

6 Troubleshooting ........................................................................................................................................ 36 
Unable to Locate Enado’s IP Address ........................................................................................................................................................ 36 
Devices Aren’t Being Controlled .................................................................................................................................................................. 36 
Testing Commands ...................................................................................................................................................................................... 36 
Activity Layouts Aren’t Publishing .............................................................................................................................................................. 36 
Cannot Gain Remote Access ...................................................................................................................................................................... 36 
Custom Image Will Not Upload ................................................................................................................................................................... 36 
Contacting Technical Support .................................................................................................................................................................... 36 

Publication Disclaimer .................................................................................................................................. 38 
 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com


© Copyright 2018 WyreStorm Technologies | wyrestorm.com 
Enado Installation Manual | 180808 

4 of 38 
UK: +44 (0) 1793 230 343 | ROW: 844.280.WYRE (9973)   

Email: support@wyrestorm.com 
 

1 Introduction 
This Installation Guide outlines the process of installing and configuring a WyreStorm ENA-001-010 or ENA-MINI-010 controller. 

We recommend printing this page to use as a checklist for items required to install this WyreStorm product. 

 WyreStorm recommends reading through this document in its entirety to become familiar with the product’s 
features prior to starting the installation process. 

Before Beginning 
WyreStorm recommends visiting the product page before installing this product for updates to this Installation Guide as well as 
other information about this product. 

Read through this document in its entirety. ....................................................................................................................................  

ENA-001-010 or ENA-MINI-010 .........................................................................................................................................................  

Required cables and connectors to connect sources and displays. ......................................................................................  

See Installation for details on connector types and wiring guidelines. 

A/V equipment to be controlled in the system. ..............................................................................................................................  

Ethernet network components and network usernames and passwords (if applicable). ...............................................  

PC or Mac with a compatible web browser. ...................................................................................................................................  

Google Chrome, Mozilla Firefox and Apple Safari are recommended. 
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2 Product Overview 
WyreStorm Enado redefines integrators’ ability to control AV distribution systems by combining powerful hardware and intuitive, 
cross-platform software to create an end-to-end AV distribution and control system that is always on, updated and accessible. 

The Enado Controller offers exceptional performance and capability within one compact unit, designed to offer high levels of 
functionality the Enado Controller utilizes a unique software platform that scales to the highest level. 

The system can be programmed via a simple but advanced web browser application and is designed to offer maximum control 
flexibility eliminating the requirement for proprietary applications. The powerful software can run on any client device that offers 
a compatible web interface making the controller ideal for both professional and residential control. 

For further information on this product and other WyreStorm ranges, visit our website or download our latest product guide at 
wyrestorm.com 

In the Box 

1x  ENA-001-010 or ENA-MINI-010 controller 

1x  Printed Installation Guide (this document). Full manual also available for download at WyreStorm.com 

8x  CAB-IR-LINK cables (ENA-001-010 only) 

4x  RS-232 male to female DB9 cables (ENA-001-010 only) 

1x  Ethernet patch cable 

2x Rack Ears (ENA-001-010 only) 

1x  100-240v AC power cables (AUS, UK, US, EU form factors, ENA-001-010 only) 

1x  5v 2A power supply (ENA-MINI-010 only) 

  

http://www.wyrestorm.com/
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ENA-001-010 Front and Rear Panel 

Front Panel 

 

 

 
IR TX Blasters Currently not used 

 
Power LED Solid: Enado is powered on 

 
Transmission LED Flashes: Data is sent from Enado 

 
Warning LED Solid: Enado is not functioning properly 

 
IR RX Learning 
Port 

Can be used to learn IR commands from an IR remote. 

 
Power Switch Turns the Enado on or off 

 

Rear Panel 

 

 

 
Ground Terminal Can be used to ground the chassis 

 
AC Power Plug Connects to a 100-240V AC 50/60Hz AC mains outlet 

 
8 Port Ethernet 
Switch 

10/100Mbps unmanaged network switch. Connects to a LAN with a DHCP server for Enado to 
acquire an IP address 

 
IR RX Learning 
Port 

Can be used with an IR RX cable for IR learning. Performs same function as front panel IR RX 

 
IR TX Ports Are used with IR TX cables or CAB-IR-LINK integration cables to send IR commands to devices 

 
RS-232 Ports Are used to send serial commands to devices 

 
Sensor I/O Are used to triggered open or closed circuits. Requires 12volt input 

 
USB 2.0 Port Can be used for an EasySync USB to RS485 adapter. 

  

http://www.wyrestorm.com/
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ENA-MINI-010 Front and Rear Panel 

Front Panel 

 

 
Power LED Solid: Enado is powered on. 

 
Active LED Flashing: Enado is functioning properly. 

 
Blank Insert Can be used with a card insert to identify information such as an IP address. 

 

Rear Panel 

 

 
LAN Port 10/100 Mbps Ethernet port. Connects to a LAN with a DHCP server for Enado to acquire an IP 

address. 

 
RS-232 Service 
Port 

For WyreStorm use only. 

 
Power Supply 
Adapter 

Connects to a 5v 2A power supply. 

 

 

Typical Application 
A typical application for this product contains the following components.  While other items can be added to the configuration, 
the items listed below are the devices typically found in the average installation of this product.  

• ENA-001-010 
• Cable/Satellite Box(es) & Bluray player(s) 

• Network router/switch 
• WyreStorm MX-0404-HDBT-H2-KIT with POH receivers 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com
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Basic Wiring Diagram 

 

http://www.wyrestorm.com/
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ENA-MINI-010 with Global Cache Adapter 

 

http://www.wyrestorm.com/
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3 Installation 

Shelf Placement 
This product should be installed on a solid, flat, level surface such as a table, cabinet or shelf using the four included feet. The 
location should be dry, well ventilated, and out of direct sunlight. 

It is acceptable to stack multiple products one atop of the other without a ventilation space between the units. However, 
WyreStorm recommends that if using more than two or more of this product, an empty space at least 1 rack unit (1.75 in) in 
height is used between every 2 chassis. This will assist in heat dissipation and prevent thermal protection from activating due to 
overheating. 

Rack Placement 
Rack ears (mounting brackets) are included with this product for installation in a standard 19-inch equipment rack.  When 
installing in a rack, the attached feet located on the bottom of the chassis must be removed. 

Wiring and Connections 
WyreStorm recommends that all wiring for the installation is run and terminated prior to making connections to the switcher.  
Read through this section in it’s entirety before running or terminating the wires to ensure proper operation and to avoid 
damaging equipment. 

Network Wiring Guidelines 
 

• The use of patch panels, wall plates, cable extenders, 
kinks in cables, and electrical or environmental 
interference will have an adverse effect on signal 
transmission which may limit performance.  Steps should 
be taken to minimize or remove these factors completely 
during installation for best results. 

 
 

 

RS-232 Wiring 
Different devices have different requirements for the RS-232 
cables they use and the cables supplied with the Enado 
controller may not be appropriate for the selected device. 
Check the manufacturer’s specification to ensure the 

cable meets the requirements for the device. The most 
common configuration of a cable is null-modem or cross 
over as is supplied with Enado. 

 
 

IR TX/RX Guidelines 
Using WyreStorm infrared emitters and receivers is the best 
way to ensure that most IR coding formats are transmitted 
and received Other 3rd party emitters and receivers can be 
used; however, these devices must operate in the same 
manner as the WyreStorm devices. 

Due to differences in IR across 3rd party control systems 
their IR ports should never be connected directly to a 
WyreStorm system as an incompatibility may exist. 
WyreStorm offers a cable that compensates for voltage 
differences as well adjusts for differences in the pins used 
within the port. Refer to the CAB-IR-LINK product page for 
more information. 

 

IR TX Port Pinout 
Connection for IR TX (transmit) uses a 3.5mm (1/8in) mono 
plug. 

 

IR RX Port Pinout 
Connection for IR RX (receive) uses a 3.5mm (1/8in) stereo 
jack that outputs +5V DC to power the included IR receiver.  

 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com
http://wyrestorm.com/catalog/wyrestorm-ir-link-cable-for-control-system-integration
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4 Configuration 
This section provides the steps to configure this product for proper operation, please read through the entire section before 
powering on the product for the first time. 

Connection Steps 
• LAN connection to the Enado controller from a DHCP server  

• LAN connection to applicable equipment 
• IR Emitters or CAB-IR-LINK cables to applicable equipment 

• RS-232 DB9 to applicable equipment 
• Relay/Sensor connections to applicable equipment 

Please note: IR, RS-232 and Relay connections are only natively possible on the ENA-001-010. These control methods can be 
added to the ENA-MINI-010 via supported Global Caché adapters. This process is explained Adding a Global Cache Adapter. 

Locating Enado on the Network 
Both the ENA-001-010 and the ENA-MINI-010 by default are set to DHCP.  The quickest way to locate Enado’s DHCP address is 
to use the Enado Discover Tool located within the WyreStorm Management Suite. Alternatively, a generic network scanning 
software can be used to locate Enado. 

Download the Management Suite here. 

• Follow the on-screen prompts to install the Management Suite onto your PC 
• Open the WMS and launch the Enado Discover Tool 

• Press the Scan Button and allow the software to search the network for the Enado  
• Once the Enado has been found select it from the list and click the ‘Launch In Browser’ button 

 

 

  

http://www.wyrestorm.com/
mailto:support@WyreStorm.com
https://wyrestorm.com/support/management-suite
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5 Product Operation 

Accessing the User Interface 
 

Configuration User Interface 

Interface in which a project is created and 
edited. Provides full access to all settings 
within Enado. 

URL: <Enado_IP_Address>/enado/edit 

Control User Interface 

Interface in which an end-user has access. No 
editing or settings are available. 

URL: <Enado_IP_Address>/enado 

 

An Enado with no published project will prompt with the below message. Click the “Configuration Editor” link to start a project. 

 

Updating Firmware 
Before creating and editing a project check to ensure the Enado is running the latest firmware release. To do this perform the 
following steps. 

1. Navigate to the Application menu and select Update Manager 
2. If a firmware update appears, click the Install button 

 
3. Allow the Enado to perform the update.  

Please note: The Enado will need to have an Internet connection in order to search for a firmware update. 

Setting a Static IP 
Following the below steps to set a static IP address to Enado: 

1. Navigate to the Tools menu and select Network Settings 
2. Click Static as the Configuration Type 
3. Enter in an IP address, subnet mask, gateway, and DNS 
4. Click Apply Network Settings and allow the Enado to reboot 
5. When the reboot counter has finished, enter in the new IP address into your browser. 

 

Creating Your First Project 

Getting Started Guide 
The Getting Started Guide is a great place to start an initial project. It provides step-by-step guidance and all the resources you 
need to understand how to navigate the user interface. 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com
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Custom Project 
1. Navigate to the Project menu and select New.  
2. Name the project and click the Create Project button. 

 

Downloading Pre-Configured Projects 
Pre-configured project can be downloaded and imported into Enado. Pre-configured project files are available for a number of 
WyreStorm devices, such as matrices, presentation switcher and NetworkHD.  

View available project files here. 

 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com
https://wyrestorm.com/enado-templates/cat/project-templates
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Configuring Control (IR, IP, RS232) 

Controlling an Ethernet Device 
There are two methods for adding and controlling Ethernet enabled devices, perform the following: 

1. Navigate to the Tools Menu and select I/O Connectivity Settings 

2. Select the “Add Ethernet Device” button located at the bottom right of the UI. 

3. Method #1 – Detect Devices 

a. Press the Detect Devices button for Enado to scan the local area network.  

b. Select the Ethernet device you wish to control from the populated list and press Add Selected.  

 
  

c. When prompted provide the IP protocol and port number required from the Ethernet device. If you have previously 

downloaded control commands for the Ethernet Device through the Enado Command Library, protocol and port 

information may be available by selecting from the Device Libs drop down menu. 

 
 

http://www.wyrestorm.com/
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4. Method #2 – Manually Add a Device 

a. Press the Add Custom button 

b. A blank “Ethernet Device” will be added. Press the Edit button to adjust the Name, IP address, protocol and port 

number. 

 

If an Ethernet device requires a login/authentication to issue commands, credentials can be added by clicking Additional 
Parameters on an added connection. 

The available parameters to choose from are listed below: 

Login Prompt 
Prompt which appears from a terminal window when attempting to login into the 
device. For example, a login prompt could show as < login: > 

Username 
Username required by the device. May require a line feed and carriage return to follow 
username. For example, < yourusername\r\n > 

Password Prompt 
Prompt which appears from a terminal window when attempting to login to the device. 
For example, a password prompt could show as < password: > 

Password 
Password required by the device. May require a line feed and carriage return to follow 
password. For example, < yourpassword\r\n\ > 

 

 

Controlling a Serial Device 
1. Navigate to the Tools Menu and select I/O Connectivity Settings 

2. Adjust one of the 4no. RS-232 port settings by selecting Edit (ENA-001-010 only) 

From the Serial Configuration pop-up, configure the 
following: 

• Port name (for easy identification) 
• Baud Rate 

• Data Bits 
• Stop Bits 

• Parity 
• Raw Mode 

 

 

Controlling an IR Device 
IR Ports do not require any configurations, however, aliases can be assigned to the ports for easy identification.  

1. Navigate to the Tools Menu and select I/O Connectivity Settings 
2. Select Show Outputs button located next to IR Outputs 
3. Click Edit next to the appropriate IR output (ENA-001-010 only) 

 

Adding a Global Cache Adapter 
1. Navigate to the Tools Menu and select I/O Connectivity Settings 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com
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1. Click the Add Port Adapter/Expander button 
2. Select an adapter model number from the drop down menu 
3. Once added, select Edit to input the adapter’s IP Address. 

 

Please note: As of Enado v5.0.0 firmware the following Global Cache devices are supported: 

• GC100-6 

• GC100-12 
• iTach IP2IR 

• iTach Flex/WiFi (3-way IR cable) 

• iTach Flex/WiFi (single IR emitter) 

• iTach Flex/WiFi (RS-232 cable) 
• iTach IP2SL 

• EasySync USB to RS485 

 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com


© Copyright 2018 WyreStorm Technologies | wyrestorm.com 
Enado Installation Manual | 180808 

17 of 38 
UK: +44 (0) 1793 230 343 | ROW: 844.280.WYRE (9973)   

Email: support@wyrestorm.com 
 

Downloading Device Commands 

Enado Command Library 
Provides command sets for a large number of 
device including WyreStorm products. 
Command types vary from IR, IP or RS232 

Global Cache Library 
Provides access to Global Cache’s database. 
Contains a vast database of IR only 
commands. 

 

To download commands, perform the following: 

1. Navigate to the Libraries menu and select Active Device Commands 
2. Click the Add Device(s) button 
3. From the drop down menu choose either the Enado Command Library or the Global Cache Database 
4. From the second drop down menu choose a manufacturer and then device 

Please note: In order for the Enado to populate the list of available command sets an Internet connection is required. 

 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com
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Importing Custom Commands 
If a large amount of custom commands need to be imported into the Enado database, an XML file can be created and imported. 
The XML must be in plain text UTF-8 and can host an unlimited number of commands to expedite the process. An Excel 
spreadsheet can be created and used for the generation of commands.  

1. Header 1 information: <device name=” “ manufacturer=” “>.  
2. Header 2 information: <allcommands generated-by=” “>.  
3. Command string information: <command id=” “ type=” “>DEVICE COMMAND DATA</command> 
4. Closing brackets: </allcommands> </device>. These belong at the end after all device commands have been created. 
5. In Enado navigate to the Libraries menu and select Active Device Commands 
6. Select the Import Device button and select the XML file 
7. To view the commands and to ensure they have imported correctly navigate to the Tools menu and select Device 

Command Creator 

The below image shows an example XML file. Any XML created should follow the same formatting for proper import into Enado. 

 

http://www.wyrestorm.com/
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Viewing and Testing Commands 
The Device Command Creator is the home for accessing, editing and testing commands. This tool hosts many features 
including: 

Command Data – Choose a Manufacturer > Device > 
Command to view or edit a command’s data. 

 

Data Format Guide - lists the appropriate syntax for 
different formats of commands, including carriage return, 
line feed and delimiter information. 

 

 

 

IR Learning - accomplished by clicking the Start Learning 
button and pointing an IR remote at either the IR RX on the 
front panel or by plugging an IR RX cable in to the IR IN 
port at the rear panel. 

Please note: IR Learning is only possible on the ENA-001-
010. WyreStorm cannot guarantee accuracy of learning IR 
commands due to varying environmental factors which 
can inhibit Enado’s ability to receive correct data. 

 

 

Testing Commands 

1. Select the command to be tested by choosing 
Manufacturer > Device > Command 

2. In the Testing section click the Set Test Outputs 
button and ensure that the appropriate I/O of Enado is 
selected 

3. Click the Test Command button 

 

 

http://www.wyrestorm.com/
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Adding Control Buttons 
There are many types of buttons throughout the Enado interface. Each type of button serves a unique purpose. 

Zone/Room 

Allow navigation into a Zone/Room for a 
project. Can also be used to designate an 
output of a matrix.  

Added to a page the Zone/Room page by 
pressing the Quick Insert plus button. 

 

Activity 

Located within a Zone/Room. Typically, a 
link to an “Activity Layout”. An Activity 
Layout links to control a source device or 
can double as a matrix input selection.  

Added to an Activity page by pressing the 
Quick Insert plus button.  

 

Shortcut 

Unique per Zone/Room. Always appear at 
the top right of the interface. Can be 
programmed in the same way as an 
Activity button. 

Added to an Activity page by pressing the 
Quick Insert plus button. 

 

Global 

Unique per Zone/Room. Always appear at 
the bottom right of the interface. Cannot 
be linked to an Activity Layout. Are 
typically used for volume or display power 
commands. 

Added to an Activity page by pressing the 
Quick Insert plus button. 

 

Control 

Buttons that are located within an Activity 
Layout. Offer the broadest configuration 
options. These are typically buttons that 
control source devices.  

Added to an Activity Layout from the top 
menu by select Insert>Button Group> 
Custom OR From Library 

 

 

http://www.wyrestorm.com/
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Editing Button Properties 
To edit any type of button, simply left the button and choose Edit Properties. The properties pane offers a number of options. 

Appearance Options 
 

 

 
Changes the name of the button. Will be shown on button if no image is associated. 

 
Associates an image with the button.  

 
Changes the font color of the button name. Will only appear if no image is associated. 

 
Changes the width of the button with the button group. 

 
Changes the font size of the button name. Will only appear of no image is associated. 

 
Changes the height of all buttons in a row. 

 

Functionality Options 
 

 

 

Yes: Allows end-user to re-program button with commands available in Activity Layout. (Typically used for cable 
TV channel favorites). 

No: No end-user adjustments can be made. 

 
Allows a command to be assigned to the button from commands available in local Enado database. 

 
Can be used to remote execute any commands that have been added to the button. 

 

Allows a function to be assigned to the button. A typical function can be used to launch 3rd-party mobile apps, 
including NetworkHD Touch.  

(Launching apps is only supported on iOS and Android devices. The app must be installed on the mobile device 
prior in order to launch. Enado will need access to the internet in order to initially add a function).  

 

Hide and Show Button Groups 
The ability to Hide or Show specific button groups allows Activity Layouts to be designed with more creativity and functionality. 
This allows more control functionality without the clutter or hassle to find the right button. To create a function to Hide/Show a 
button group perform the following. 

1. Navigate into an Activity Layout 
2. Left click a button group to be hidden or shown and select Edit Group 
3. Click the Reference ID field and type in a name. This is what is referenced when a button group is chosen to be hidden or 

shown. It cannot have any spaces. 
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4. Click the Finish Editing button  
5. Select a button that will trigger the hide/show function and choose to edit its properties.  
6. Select the Edit Properties pencil icon next to Function 
7. Select the drop down menu from the Editing Functions pop-up and choose to hide or show an element. 
8. Select the second drop down menu and choose the Reference ID that was created for a button group. 

 
9. Click the Add Function button and then click Done. 

Please note: The initial state of a button group can be toggled between Visible and Hidden. By default, a button group’s state will 
be visible. 

 

 

Launching 3rd-Party Apps 
3rd-Party applications installed on iOS or Android devices can be launched directly from the Enado interface. To program a 
button to launch an app, perform the following steps. 

1. Navigate to the desired button 
2. Left click and select Edit Properties 
3. Click Edit (pencil icon) next to Function 
4. Select Launch Application and then choose the desired app. 
5. Click Add Function 

 

Note: Enado must have an active internet connection in order to populate the list of apps. 
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Source Control (Activity Layouts) 
Activity Layouts are “templates” that host Control buttons for a source device or specific actions. Activity Layouts are linked to 
Activity buttons in a project. There are two methods to using Activity Layouts, downloading pre-configured layouts or creating 
custom.  

Downloading Pre-Configured Layouts 
There are a number of Activity Layouts available for download at www.WyreStorm.com. To import a pre-configured Activity 
Layout, perform the following steps. 

1. Navigate to the Libraries menu>Online Libraries or click here. 
2. Select the Activity Templates link at the top of the page. 
3. Download any appropriate template. Unzip the download to access the individual Activity Layout files. 

 
 

4. Navigate to the Libraries menu >Activity Layouts 
5. Select the Import button and upload the template(s) downloaded from the Online Libraries 
6. Navigate to the button you wish to link to the Activity Template. 
7. Left click and choose Edit Properties 
8. Select Edit (pencil icon) next to Activity Layout and select the template. 

 

Creating Custom Activity Layouts 
1. Navigate to the Libraries menu and select Activity Layouts.  
2. Click the Add New Layout button 
3. Name the layout and then click Create & Edit 
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Wizards 
There are a number of tools available in Enado which can simplify and decrease programming time. Each tools serves a specific 
purpose.  

Matrix I/O Assignment 
The Matrix I/O Assignment Tool allow commands to quickly be assigned to Activity buttons, whether commands are for matrix 
input/output switching or just creating a generic macro. 

1. Navigate to the Tools menu >Matrix I/O Assignment 
2. From the first drop down menu select a device manufacturer  
3. From the second drop down menu select a device 
4. Choose to overwrite, prepend or append any existing commands on existing Activity buttons 
5. Select the desired port for the commands to utilize (configured in I/O Connectivity settings) 
6. Click the next button and select the desired commands for any existing Activity buttons 

 
 

Activity Port Assignment 
The Activity/Port Assignment Tool allows easy programming of Activity button names, icons, linked Activity Layouts and I/O 
port. Access this tool by navigating to the Tools Menu>Activity/Port Assignment. 

Please note: Any changes made from this tool will require a browser refresh to reflect changes. 

 

http://www.wyrestorm.com/
mailto:support@WyreStorm.com


© Copyright 2018 WyreStorm Technologies | wyrestorm.com 
Enado Installation Manual | 180808 

25 of 38 
UK: +44 (0) 1793 230 343 | ROW: 844.280.WYRE (9973)   

Email: support@wyrestorm.com 
 

Command Assignment Tool 
The Command Assignment Tool (CAT) is used to perform bulk command assignments to buttons located in an Activity Layout. 
To access the CAT, navigate to the Tools Menu>Command Assignment. 

The CAT will automatically list all assigned Activity Layouts for a project. Activity Layouts must be assigned to Activity Buttons in 
order to appear in the CAT. 

1. From the drop down menus choose the appropriate Manufacturer and Device command set. If no values appear in the drop 

down menu, the Enado command database does not contain any commands and must be downloaded. Refer to the 

section: Downloading Device Control Commands. 

2. Choose the appropriate Assignment Mode.  

a. Overwrite: will erase any existing commands associated with Activity Layout buttons and write new commands. 

b. Append: will keep any existing commands associated with Activity Layout buttons and will append any newly 

written commands. 

 
 

3. Press Next, to begin assigning commands. By default, Enado will attempt to automatically associate the names of buttons 

to the command names in the chosen library.  

4. Manually select commands from the drop down menus for any remaining buttons. 

 

Uploading Custom Icons 
Enado comes pre-loaded with a library of Room, Activity and Button icons. All of these images can be viewed by navigating to 
the Libraries menu and selecting Images/Icons. Initially a drop down menu will appear which lists the different icon categories. 
Once a category is selected the corresponding icons will appear. 

 

Custom icons can be uploaded in the Icon/Image library by selecting either the Upload Multiple or Single Image button. The 
format of any icon that is uploaded into the Icon/Image library needs to be a PNG. 

 

Visual Theme 
The visual theme for a project can be adjusted by navigating to the Project menu and selecting Visual Theme. To create a 
custom theme, perform the following steps. 

1. Click the New Theme button and give it a name 
2. Select Custom Hue to adjust the colors of the top and bottom menu bars 
3. Select Background to upload a custom background image. This must be in a PNG or JPEG format 
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Please note: The size of this image will affect how quickly the Enado UI loads on the control device. Keep image size to a 
minimum. 

QR Codes 
QR codes can be generated directly from the Enado configuration UI for access into any Project or Room or Activity in a Project. 
The project QR code is available when publishing or to generate QR codes for specific rooms or activities in rooms, perform the 
following steps. 

1. Navigate to the Project menu and hover over Links/QR Codes 
2. Choose to generate either Room or Activity QR codes 
3. Allow the Enado to automatically generate the QR codes 
4. Download or print the codes and scan them with a mobile device 

 

 

Please note: A third party app may need to be downloaded to a mobile device in order to scan the QR code. 
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Remote Access 
Enado can have remote access configured to allow a connection from outside its LAN. Each Enado controller generates a unique 
Permalink address. A Permalink address acts in the same way as DynamicDNS, if Enado’s LAN IP address were to change the 
Permalink URL will still allow access into the controller. To setup remote access perform the following steps. 

1. Navigate to the Tools menu and select Remote Access Options 
2. Adjust the port number (optional) 
3. Adjust the System Name (optional) 
4. Generate an API Key 

 
 

5. Navigate to the Application menu and select Preferences  
6. Ensure that the Control UI settings are enabled 
7. Open the live user interface and select the “Gear” icon at the bottom right 
8. Click Manage System Passwords then choose Create New Password 
9. Enter in the desired password and click confirm 
10. Click the Enable button. A green “ON” indicator should appear 

 

Once Enado’s remote access options have been configured the network router will need port forwarding adjusted. To do this 
perform the following steps. 

1. Login to the network router and locate the port forwarding options 
2. Set the external port to the same port number configured in Enado 
3. Set the internal port to port 80 
4. Set the IP address to match the IP address for Enado 

Controllers can also be accessed remote via the Remote Access Portal, at https://www.myenado.com/mycontroller/.  Type in 
the controller’s System Name and follow the on-screen instructions to access the controller. 

For additional information or help on configuring a specific model router please visit portforward.com 
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Timed Commands 
Timed commands can be programmed onto either existing project buttons or through the Triggered Commands tool. To make a 
button/macro into a timed event perform the following: 

Note: Enado must be connected and maintain a connection to the internet in order to acquire local time. Configure the local time 
zone by navigating to the Preferences Menu and setting the time zone. 

1. If not done already, add control commands to a supported button in the Enado configuration interface as normal.  

2. Next to the command field from the button’s “Edit Properties” pane select the “Timer” icon 

 . 

 

 Timer 
Enable: Enables the timer 

Disable: Disables the timer 

 Execute at Specify the time of day in which to execute the command 

 Then 
End: Timer will only execute at the specified time. 

Every: Timer will execute every X minutes until end time has been reached 

 Repeat Options 

Run on: Timer will only execute on specified date. 

Daily/Weekly: Check respective day(s) to repeat 

Month/Annually: Set month and day to repeat  

 

To create a separate timed command outside of existing project buttons, perform the following: 

1. Navigate to the Tools Menu and select Triggered Commands 

2. Select Add/Edit Commands button to add the commands you wish to have triggered. 

3. Select Edit Condition button 

4. To have Enado trigger the commands via the Timer options set the drop down menu to HTTP>GET>x (where x is a value 1 – 

99) 

5. Set the timer and repeat options respectively.  

 

Triggered Commands 
Triggered commands allow the Enado controller to execute a single or multiple commands through contact closures and by 
receiving an HTTP request. Triggering via HTTP requests allows the Enado to be integrated with such devices as the Amazon 
Echo and IFTTT.com. To configure a triggered command, perform the following steps. 

1. Navigate to the Tools menu and select Triggered Commands 
2. Select the Add Triggered Command button at the bottom of the page 
3. Press Edit Condition and choose HTTP and GET 
4. Choose a unique preset number between 1 and 99 
5. Add a command(s) for the device you wish to control and adjust the port(s) accordingly 

The URL to execute a triggered command uses the following format. The network WAN IP address, trigger number and API Key 
will need to be changed to match the settings that have been configured. 

• https://<EnadoPermalink>/Enado/api/core/Triggers/<trigger ID number>/?auth_token=<API Key> 
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To trigger a command by using the contact closures simply choose CONTACT-X as the Condition. Then choose the state of the 

contact. 

Please note: For integration with IFTTT.com remote access will need to be configured. Please see the Integrating Enado & 
Amazon Echo Application Note, or the online user manual on the Help menu, for a detailed procedure on how to accomplish the 
integration. 

Adding a Video Preview  
Enado has the ability to enable video feedback using a compatible encoded web stream. These web streams must support 
Motion JPEG snapshots (MJPEG or MJPG). Many CCTV DVR & IP cameras natively support this format. Please check with the 
manufacturer to ensure a system is compatible with this format. 

Video sources with composite video outputs can be converted to IP streams using Axis video encoders. For information on how 
to add a web stream from an Axis encoder please review the Enado Video Integration Guide Application Note or visit the online 
user manual via the Help menu. 

To add a web stream from a CCTV DVR or IP camera please refer to the manufacturer’s documentation to acquire the 
appropriate URL required for feedback in Enado. Once the appropriate URL is acquired perform the following steps in Enado. 

1. Navigate to the Tools menu and select Video Source Settings 
2. Select Custom Path from the drop down menu 

 
 

3. Enter in the URL for the CCTV or IP camera and click the Add button 
4. Navigate into an Activity Layout 
5. Navigate to the Insert menu and select Video Element 
6. Left click on the imported video element and choose Edit Properties 
7. Select the Pencil icon (Edit properties) next to Video Source 
8. Select the custom path video URL and click OK 

 
 

9. Publish the project for the video element to show in the Live UI 

 
 

NetworkHD Encoder preview streams can be viewed 
in Enado by utilizing the same steps listed above. 
Create a Custom Path in the Video Source Settings 
with the appropriate encoder URL.  

 

NHD-100 & 200 Encoders: TX_IP_ADDR/capture.jpg 

NHD-400 Encoder: TX_IP_ADDR/capture.jpg  

Example URL: 192.168.1.242/capture.jpg 
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Integrating Amazon Echo (Alexa) 
Integrating Amazon Echo with Alexa voice service requires an active MyEnado subscription. A MyEnado subscription can be 
purchased from the Enado editor by navigating to Tools>Remote Access Options. 

1. Select the desired button/macro you wish to turn into a voice enabled command and choose edit properties 
2. Click the edit (pencil) icon next to Function 

 
 

3. From the drop down menu choose Voice and then click Add Function 
4. When prompted type in the phrase you wish to be recognized by Alexa. For example, if the corresponding button was 

programmed to power on a TV, the voice phrase could be called “Turn on Living Room TV”. 

 
 

5. Click Ok when finished 
6. Repeat the above steps for any additional control buttons 
7. Navigate to Tools>Remote Access Options 
8. Generate a Voice Service Code and make note of the number 

 
 

9. Navigate to Project>Preview/Publish and select Publish to push the configuration. 

 
 

The Enado skill will need to be enabled for your Amazon Echo device(s). To enable the Enado skill, perform the following: 
 
1. Open the Amazon Alexa app on your iOS or Android device 
2. Select the menu button at the top left and choose Skills & Games 
3. Type Enado Voice in the search field to locate the Skill 
4. Tap the Enable button 
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You will now need to link the Amazon Echo to the Enado controller. Follow the below dialog steps to successfully create the link. 
 

User Dialog  Alexa Response 

“Alexa, open Enado” Hello, how can I help? 

“Register voice service” 
Please tell me your voice service code, starting with “Service 
code…” 

“Service code {123 456}”  
(replace with service code generated by your Enado 
controller) 

Please tell me device’s location by starting with “Device in…” 

“Device in {room}”  
(name of room in Enado project a voice command exists 
within) 

Congratulations, device has connected to {room} voice service. 

 
Repeat the above dialog for additional rooms that have voice commands. When finished, you can execute any voice commands you 
have created. 
 
Example Command  #1 Alexa Response 

“Alexa, open Enado” Hello, how can I help? 

“Turn on Living Room TV” Ok, anything else? 

“Start Netflix” Ok, anything else? 

“No” - 

 
Example Command #2 Alexa Response 

“Alexa, tell Enado to turn on Living Room TV” Ok 

 
Example Syntax 

“Change channel to {num}” 

“Change {device} channel to {num}” 

“Change {device} channel to {num} in {room}” 

“Set temperature to {num}” 

“Set {room} temperature to {num}” 

“Enter {room}” 

“Control {device}” 

“Control {device} in {room}” 

 

To view a compiled list of all voice commands created with respective Rooms, Activities and buttons navigate to Project>View/Print 
Voice. 
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Publishing a Project 
In order for a project to be accessed through the live user interface it needs to be published. To publish a project, perform the 
following steps. 

1. Navigate to the Project menu and select Preview/Publish 
2. Click Publish 

The publish menu will also generate a QR code that can be scanned from a mobile device. The QR code will automatically direct 
a device to the live user interface. To copy the QR code for use elsewhere simply right click it and select Copy. 

 

When accessing the Live UI of Enado the latest published project will load by default. Multiple published projects can be 
accessed simultaneously by adjusting the project number in the URL. 

http://192.168.0.241/enado/live.php?project=33 

The number 33 in the Live UI URL above can be changed to reflect another published project in Enado. Simply publish a second 
project in Enado and note the number associated with the project in the URL. 
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Preferences Menu 
Controller preferences can be adjusted to enable or disable specific features of Enado. Navigate to the Application menu and 
select Preferences to make the following adjustments: 

 

 Timezone 
Allows Enado to report accurate time based on location. Correct timezone is 
required when programming timed commands. 

 Editor Password 

Enabled: Enado will prompt for a password when logging into the configuration 
UI. 

Disabled: The configuration UI will not be password protected 

 
Remote Access 
Authentication 

Enabled: Enado will prompt for a password if remotely accessing the interface. 

Disabled: Enado will not prompt for a password if remotely accessing the 
interface. 

 
Control UI Settings 
Icon 

Enabled: A settings icon will appear in the control UI and will be accessible to the 
end-user, allowing limited settings to be adjusted outside of the configuration UI. 

Disabled: No settings icon will appear in the control UI 

 Single Zone Link 

Enabled: Will show a project’s Zone/Room button when there is only a single 
Zone/Room 

Disabled: Will not show a project’s Zone/Room button when there is only a 
single Zone/Room and will automatically log the end-user into the Activity 
selection page. 

 Single Activity Link 

Enabled: Will show a project’s Activity Button page even if there is only a single 
Activity Button. 

Disabled: Will not show a project’s Activity Button page when there is only a 
single Activity Button and will automatically log the end-user into the Activity. 
*Requires the Single Zone Link to be disabled. 

 Zone Terminology 
Enter in customer “Zone” naming. This name will appear at the top navigation 
bar in the control UI. 
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Project & Controller Backup 
WyreStorm recommends always keeping a current backup of the Enado controller. To create a full controller backup, perform 
the following steps. 

1. Navigate to the Tools menu and select Export/Backup Controller 
2. Allow the Enado to compile the controller backup and then click the download link 

To create project backups, perform the following steps. 

1. Navigate to the Project menu and select Export Project to File 
2. Allow the Enado compile the project and then click the download link 

Please note: The Export Project to File option will only export the currently selected project. To select a different project for 
exporting navigate to the Project menu, hover over Open/Import and then My Projects. 

GPIO (Relays & Sensors) 
The ENA-001-010 features a set of relays and sensors. These relays can be used for numerous applications such as triggering a 
projector screen up or down. The below diagram demonstrates connections from Enado to a projector screen control box. 

A closed circuit can be toggled from the Enado UI which will allow 12volts to be sent to the projector screen control box. When 
12volts is received, depending on the manufacturer, the screen will go up or down. 

 

To create the relay trigger from the Enado UI perform the following steps. 

1. If not done already, create a button in an Activity Layout. 
2. Select the button and choose Edit Properties. 
3. Next to the Command field, select the Edit (Pencil) icon. 
4. Click the Add Relay Command button. 
5. Choose the appropriate relay and its state, On or Off. 
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6 Troubleshooting 

Unable to Locate Enado’s IP Address 
• Ensure that Enado is connected to a DHCP server to acquire an IP address. 

• Ensure your PC is on the same network and IP range set the IP address range to the same range you believe the Enado is in 
and use a subnet mask of 255.0.0.0. 

• Use the Enado Discover Tool to search for the unit and reset it to DHCP. 

Devices Aren’t Being Controlled 
• Ensure commands have any required Carriage Return and Line Feeds and it does not have any extra spaces. 
• Enado I/O ports have been configured correctly for a device – check with the manufacturers API. 

• Activity Layouts/buttons have been assigned an I/O port. 
• Wiring pinout is correct per device specifications. 
• Consider attempting to control a device through additional third party software such a terminal emulator. 

• Reboot the Enado controller. 

Testing Commands 
1. Navigate to the Device Command Creator located in the Tools menu 
2. Select the command to be tested by choosing the Manufacturer, Device and then the Command 
3. In the Testing section click the Set Test Outputs button and ensure that the appropriate I/O of Enado is selected 
4. Click the Test Command button 

Activity Layouts Aren’t Publishing 
1. Navigate to the Project menu and select View/Print Details 
2. Verify that all Activity buttons that should have a layout linked do not show << NO LINKED ACTIVITY>> 

 

Cannot Gain Remote Access 
• Remote access password has been enabled – Enable the User Interface settings in Application>Preferences, then in the user 

interface press the setting icon and Manage Passwords. Create a new password and enable it. 
• Ensure the Network router has port forwarding configured to match port number and IP address for Enado. 

• Check that the Forwarded port number has not been blocked by the ISP. 

Custom Image Will Not Upload 
• Ensure that the image is in a PNG format for buttons or PNG or JPG for Theme backgrounds. 

Contacting Technical Support 
Phone: UK: +44 (0) 1793 230 343 | ROW: 844.280.WYRE (9973)  
Email: Support@WyreStorm.com 
On Line Chat (Accessible through website): http://WyreStorm.com/Contact-Tech-Support 
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7 Document Revision History 
V3.0 - August 2018 

Various Sections Added content regarding Enado version 5 
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